FAQ
  • 09 Sep 2022
  • 2 Minutes To Read
  • PDF

FAQ

  • PDF

Looking for some frequently asked questions when building a Lookup Adaptor? This guide is for you!

Lookup Adaptor FAQs

Auto-Linking

Use the Autolinking Debugger to quickly test and debug Profile auto-linking issues.

My Profile is not Auto-Linking, but I am sending back a response to Gladly's Auto-Link request. What's happening?

  • Check if Auto-Linking is turned on in App Settings.
  • Check if your response is properly formatted.
  • Check if you are only returning one result in your response.
  • If emails is set to Auto-Link, confirm at least one of the emails you responded back with equals the email address in the Customer profile.
  • If phones is set to Auto-Link, confirm at least one of the phones you responded back with equals the phone number in the Customer profile.

I am not receiving a request to Auto-Link a profile, even though it is unlinked. Why is this?

  • Any Profile that has been unlinked in the past will never issue another Auto-Link request again.

Basic Search

Use the Basic Lookup Debugger to quickly test and debug Profile manual linking issues.

I don't see any Basic Search Results. Why?

Basic search results appear, but I'm not seeing the columns I want. Why?

  • Check if you've set up the appropriate display fields for your results table.
  • Check if your Basic Search response returns results that match your table columns as documented here.

Basic search results appear, but linking fails. Why is this?

  • This typically occurs when DETAILED Lookup fails
  • Check to see if DETAILED Lookup is returning a properly formatted response (e.g.: contains externalCustomerId, only one result back).

DETAILED Lookup

I am sending X custom attribute but it is not showing in the customer profile. How can I get it to show up?

  • You must engage with the Gladly Professional Services team to display this. Please supply the attribute display name, the location to display it, and the attribute identifier to expedite configuration.

My Agent deleted a phone number/email address from the Customer Profile. When they refreshed the page, it came back. Why?

  • Your Lookup Adaptor returned the phone number/email address in a DETAILED Lookup response.

I sent back an email address in my DETAILED lookup response, but I am not seeing it in the Gladly Customer Profile. However, it looks like the Profile is linked properly. Why is this?

  • It is likely another Customer Profile on Gladly is associated with this email address, so it has been silently dropped from the Profile.

I sent back a DETAILED lookup response, but it is not showing updated values on Gladly. Why is this?

  • This typically occurs when DETAILED Lookup fails.
  • Check to see if DETAILED Lookup is returns a properly formatted response (e.g.: contains externalCustomerId, only one result back).

Can I nest values in customAttributes?

  • No.

I sent back an imageUrl field for each of my products, but it is not displaying when Agents hover over the product. Why?

  • Check if your imageUrl is a valid HTTPS link.

Was this article helpful?

What's Next